Hi all, Let's Encrypt have changed their intermediate certficate signing and if you arer using them for your secure/super nodes Please follow https://horizenofficial.atlassian.net/wiki/spaces/ZEN/pages/1715535876/Error+message+unable+to+verify+the+first+certificate to resolve kind regards, Read More